What’s Vulnerable › Vulnerabilities
CVE-2026-12720: Kirki < 6.0.13 - Unauthenticated PHP Object Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-31 · updated 2026-08-26
- Weakness: CWE-502
Description
The Kirki WordPress plugin before 6.0.13 does not restrict which classes may be instantiated when it deserialises data that unauthenticated users can store, leading to PHP Object Injection that is triggered when an administrator later reviews the stored data. With a suitable gadget chain present on the site (via another installed Kirki WordPress plugin before 6.0.13, , or an outdated WordPress version), this could be leveraged to perform a variety of attacks, such as remote code execution.
Affected products
- Kirki: before 6.0.13 — fixed in 6.0.13
How to fix
Upgrade to a fixed version: Kirki 6.0.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12720 or the next vulnerability affects your stack