What’s Vulnerable › Vulnerabilities
CVE-2026-12746: Dancer2::Plugin::Auth::OAuth::Provider versions before 0.23 for Perl do not support the OAuth 2.0 state parameter
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-04 · updated 2026-10-25
- Weakness: CWE-352
Description
Dancer2::Plugin::Auth::OAuth::Provider versions before 0.23 for Perl do not support the OAuth 2.0 state parameter. The authentication_url method builds the provider authorization redirect without issuing a state value, and the callback method exchanges the callback code and registers the resulting token into the session without verifying that the callback corresponds to an authorization request this session initiated. Any application that uses this plugin for OAuth 2.0 login is exposed to login cross-site request forgery: because the callback is not bound to the session that began the flow, an attacker who starts an authorization with their own provider account can deliver the resulting callback to a victim, causing the victim's session to complete the attacker's authorization and associating the attacker's provider identity and access token with that session. Where the application persists this as an account link, the attacker may retain access to the victim's account through their own provider credentials.
Affected products
- BIAFRA Dancer2::Plugin::Auth::OAuth::Provider: before 0.23 — fixed in 0.23
How to fix
Upgrade to a fixed version: BIAFRA Dancer2::Plugin::Auth::OAuth::Provider 0.23. Check the vendor advisory for mitigations.
References
- https://datatracker.ietf.org/doc/html/rfc6749#section-10.12
- https://github.com/biafra/perl-Dancer2-Plugin-Auth-OAuth/commit/806420fc2abbe13bede4461475f2f3dcd7daf5f2.patch
- https://metacpan.org/release/BIAFRA/Dancer2-Plugin-Auth-OAuth-0.23/diff/BIAFRA/Dancer2-Plugin-Auth-OAuth-0.22
- http://www.openwall.com/lists/oss-security/2026/07/04/9
Get alerted when CVE-2026-12746 or the next vulnerability affects your stack