What’s Vulnerable › Vulnerabilities
CVE-2026-12770: BerriAI litellm Admin Key key_management_endpoints.py improper authorization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-21 · updated 2026-10-25
- Weakness: CWE-266
Description
A vulnerability was determined in BerriAI litellm up to 1.63.1. The impacted element is an unknown function of the file litellm/proxy/management_endpoints/key_management_endpoints.py of the component Admin Key Handler. This manipulation causes improper authorization. The attack can be initiated remotely. The exploit has been publicly disclosed and may be utilized. Patch name: 23781. It is recommended to apply a patch to fix this issue. The vendor was contacted early about this disclosure.
Affected products
- BerriAI litellm: before 1.63.2 — fixed in 1.63.2
How to fix
Upgrade to a fixed version: BerriAI litellm 1.63.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/YLChen-007/993c68152b2c770d53590f1684c755d4
- https://github.com/BerriAI/litellm/
- https://github.com/BerriAI/litellm/pull/23781
- https://vuldb.com/cve/CVE-2026-12770
- https://vuldb.com/submit/811279
- https://vuldb.com/vuln/372512
- https://vuldb.com/vuln/372512/cti
Get alerted when CVE-2026-12770 or the next vulnerability affects your stack