What’s Vulnerable › Vulnerabilities
CVE-2026-12773: BerriAI litellm MCP Proxy user_api_key_auth_mcp.py UserAPIKeyAuth improper authentication
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-21 · updated 2026-10-25
- Weakness: CWE-287
Description
A weakness has been identified in BerriAI litellm up to 1.59.8. Affected is the function UserAPIKeyAuth of the file litellm/proxy/_experimental/mcp_server/auth/user_api_key_auth_mcp.py of the component MCP Proxy. Executing a manipulation can lead to improper authentication. The attack may be launched remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure.
Affected products
- BerriAI litellm: before 1.59.9 — fixed in 1.59.9
How to fix
Upgrade to a fixed version: BerriAI litellm 1.59.9. Check the vendor advisory for mitigations.
References
- https://gist.github.com/YLChen-007/3cfaad10a69d7a15e4d4d458cb53309e
- https://vuldb.com/cve/CVE-2026-12773
- https://vuldb.com/submit/811282
- https://vuldb.com/vuln/372515
- https://vuldb.com/vuln/372515/cti
- https://access.redhat.com/security/cve/CVE-2026-12773
- https://bugzilla.redhat.com/show_bug.cgi?id=2491112
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-12773.json
- https://vuldb.com/submit/811282
Get alerted when CVE-2026-12773 or the next vulnerability affects your stack