What’s Vulnerable › Vulnerabilities
CVE-2026-12822: langflow-ai langflow Bundle URL Loader code injection
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-22 · updated 2026-10-25
- Weakness: CWE-74
Description
A vulnerability was identified in langflow-ai langflow up to 1.9.3. This affects an unknown function of the component Bundle URL Loader. The manipulation leads to code injection. The attack needs to be performed locally. The vendor was contacted early about this disclosure but did not respond in any way.
Affected products
- IBM Langflow OSS: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/dxz0069/softwareoverflow/blob/main/langflow_bundle_url_custom_component_startup_rce_vulndb.md
- https://vuldb.com/cve/CVE-2026-12822
- https://vuldb.com/submit/837582
- https://vuldb.com/vuln/372612
- https://vuldb.com/vuln/372612/cti
- https://github.com/dxz0069/softwareoverflow/blob/main/langflow_bundle_url_custom_component_startup_rce_vulndb.md
Get alerted when CVE-2026-12822 or the next vulnerability affects your stack