What’s Vulnerable › Vulnerabilities

CVE-2026-1285: Potential denial-of-service vulnerability in django.utils.text.Truncator HTML methods

Description

An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28. `django.utils.text.Truncator.chars()` and `Truncator.words()` methods (with `html=True`) and the `truncatechars_html` and `truncatewords_html` template filters allow a remote attacker to cause a potential denial-of-service via crafted inputs containing a large number of unmatched HTML end tags. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Seokchan Yoon for reporting this issue.

Affected products

How to fix

Upgrade to a fixed version: Django 4.2.28, 5.2.11, 6.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-1285 or the next vulnerability affects your stack