What’s Vulnerable › Vulnerabilities
CVE-2026-12869: Header Footer Builder for Elementor < 1.2.1 - Contributor+ Stored XSS via Template Import
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-16 · updated 2026-07-16
- Weakness: CWE-79
Description
The Header Footer Builder for Elementor WordPress plugin before 1.2.1 does not require an administrative capability for its dashboard template-import action (it allows any edit_posts user), so a Contributor can import a template containing an Elementor HTML widget configured to display site-wide, injecting JavaScript that executes in the session of any visitor or administrator who loads the site.
Affected products
- Header Footer Builder for Elementor: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: Header Footer Builder for Elementor 1.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12869 or the next vulnerability affects your stack