What’s Vulnerable › Vulnerabilities
CVE-2026-12878
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-09-28
- Weakness: CWE-269
Description
In affected versions of the Codefresh platform an authenticated user can utilize an API endpoint to elevate to Admin permissions.
Affected products
- Octopus Deploy Codefresh: from 2.0.0 before 2.11.15 — fixed in 2.11.15
How to fix
Upgrade to a fixed version: Octopus Deploy Codefresh 2.11.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12878 or the next vulnerability affects your stack