What’s Vulnerable › Vulnerabilities
CVE-2026-12887
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-27 · updated 2026-10-27
Description
In affected versions of Octopus Server, a user with permission to upload a malicious nuget package is able to deploy a script step so the script executes outside of the parent directory.
Affected products
- Octopus Deploy Octopus Server: from 2023.0.0 before 2026.1.674; from 2026.1 before 2026.1.674; from 2026.2 before 2026.2.973; from 2026.3 before 2026.3.5839 — fixed in 2026.1.674, 2026.2.973, 2026.3.5839
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2026.1.674, 2026.2.973, 2026.3.5839. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12887 or the next vulnerability affects your stack