What’s Vulnerable › Vulnerabilities
CVE-2026-12901: GetPaid < 2.8.55 - Unauthenticated Worldpay Payment Bypass via Insufficient IPN Verification
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-08-26
- Weakness: CWE-345
Description
The GetPaid WordPress plugin before 2.8.55 does not verify the authenticity of incoming Worldpay payment notifications, allowing unauthenticated attackers to forge a notification that marks a pending invoice as paid without any payment being made.
Affected products
- GetPaid: before 2.8.55 — fixed in 2.8.55
How to fix
Upgrade to a fixed version: GetPaid 2.8.55. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12901 or the next vulnerability affects your stack