What’s Vulnerable › Vulnerabilities
CVE-2026-12940: Langflow is affected by remote code execution due to multiple unauthenticated and insufficiently authorized API endpoints
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-78
Description
IBM Langflow OSS 1.0.0 through 1.10.1 are vulnerable to unauthenticated remote code execution via environment variable injection in the MCP (Model Context Protocol) stdio launcher. The vulnerability exists in src/lfx/src/lfx/base/mcp/util.py where the DANGEROUS_ENV_VARS blocklist fails to include SHELLOPTS , BASHOPTS , and PS4 environment variables.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.2 — fixed in 1.10.2
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12940 or the next vulnerability affects your stack