What’s Vulnerable › Vulnerabilities
CVE-2026-12942: Langflow is affected by path traversal due to multiple unauthenticated and insufficiently authorized API endpoints
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-22
Description
IBM Langflow OSS 1.0.0 through 1.10.1 could allow a remote attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot " sequences ( /.. /) to view arbitrary files on the system.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.2 — fixed in 1.10.2
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12942 or the next vulnerability affects your stack