What’s Vulnerable › Vulnerabilities
CVE-2026-12957: Arbitrary Code Execution in Language Servers for AWS
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-23 · updated 2026-10-26
- Weakness: CWE-732
Description
Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.
Affected products
- Amazon Web Services Language Servers for AWS: before 1.65.0 — fixed in 1.65.0
How to fix
Upgrade to a fixed version: Amazon Web Services Language Servers for AWS 1.65.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-047-aws/
- https://github.com/aws/language-servers/security/advisories/GHSA-xhcr-j4j9-3gh7
Get alerted when CVE-2026-12957 or the next vulnerability affects your stack