What’s Vulnerable › Vulnerabilities
CVE-2026-12958: Arbitrary file write in Language Servers for AWS
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-23 · updated 2026-10-26
- Weakness: CWE-61
Description
Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.
Affected products
- Amazon Web Services Language Servers for AWS: before 1.69.0 — fixed in 1.69.0
How to fix
Upgrade to a fixed version: Amazon Web Services Language Servers for AWS 1.69.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-047-aws/
- https://github.com/aws/language-servers/security/advisories/GHSA-6v3r-4p5c-mrp5
Get alerted when CVE-2026-12958 or the next vulnerability affects your stack