What’s Vulnerable › Vulnerabilities
CVE-2026-12966: Direct Payments for WooCommerce < 2.5.3 - Unauthenticated Cross-Customer Order Tampering via digages AJAX Actions
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-08-26
- Weakness: CWE-284
Description
The Direct Payments for WooCommerce WordPress plugin before 2.5.3 does not verify that the requester owns the targeted WooCommerce order in several unauthenticated AJAX handlers before changing its status and overwriting its payment metadata, allowing unauthenticated attackers to tamper with other customers' orders, including forging a "payment sent" state, overwriting the payment-method label, and attaching forged payment-proof files.
Affected products
- Direct Payments for WooCommerce: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: Direct Payments for WooCommerce 2.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12966 or the next vulnerability affects your stack