What’s Vulnerable › Vulnerabilities
CVE-2026-12970: LearnPress < 4.4.1 - Reflected XSS via c_search
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-20
- Weakness: CWE-79
Description
The LearnPress WordPress plugin before 4.4.1 does not escape a search parameter before reflecting it into an HTML attribute, leading to Reflected Cross-Site Scripting that executes in the browser of a logged-in instructor or administrator who is tricked into opening a crafted link.
Affected products
- thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses: before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses 4.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12970 or the next vulnerability affects your stack