What’s Vulnerable › Vulnerabilities
CVE-2026-12971: LearnPress < 4.4.4 - Instructor+ Server-Side Request Forgery via openai_apply_image_feature
- Severity: low (CVSS 2.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-08-26
- Weakness: CWE-918
Description
The LearnPress WordPress plugin before 4.4.4 does not validate a user-supplied URL before the server fetches it, allowing users with the instructor role to induce the server to issue requests to arbitrary external hosts, a blind and bounded server-side request forgery.
Affected products
- thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses: before 4.4.4 — fixed in 4.4.4
How to fix
Upgrade to a fixed version: thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses 4.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12971 or the next vulnerability affects your stack