What’s Vulnerable › Vulnerabilities
CVE-2026-12982: Document Gallery < 5.1.1 - Reflected XSS via dg_generate_gallery
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-27 · updated 2026-07-27
- Weakness: CWE-79
Description
The Document Gallery WordPress plugin before 5.1.1 does not properly sanitise and escape user input before reflecting it back in the response of an unauthenticated AJAX action, leading to a Reflected Cross-Site Scripting vulnerability which can be exploited against unauthenticated users.
Affected products
- Document Gallery: before 5.1.1 — fixed in 5.1.1
How to fix
Upgrade to a fixed version: Document Gallery 5.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12982 or the next vulnerability affects your stack