What’s Vulnerable › Vulnerabilities
CVE-2026-12986
- Severity: high (CVSS 7.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-10-25
- Weakness: CWE-352
Description
A critical vulnerability in Admin GUI in Payara Server Full 4.x, 5.x, 6.x, 7.x, 7.2026.x, 6.2025.x, 6.2024.x on All platforms that allows the attacker to leak the admin gfresttoken to an attacker-controlled host that can result in a full unauthenticated takeover of Payara admin domain. A Server-Side Request Forgery (SSRF) vulnerability in the DownloadServlet of the Admin GUI in Payara Server allows a remote attacker to exfiltrate the administrator's REST session token (gfresttoken) to an attacker-controlled host via a crafted request URL. Combined with the absence of CSRF protection on DownloadServlet, an unauthenticated attacker can trick a logged-in administrator into triggering the token leak, then replay the stolen token to gain full administrative access to the Payara domain, leading to arbitrary code execution via WAR deployment. The vulnerability exists in the DownloadServlet and associated ContentSource implementations (LogViewerContentSource, LogFilesContentSource, LBConfigContentSource, ClientStubsContentSource) within the admingui:console-common module.
Affected products
- Payara Server: from 7.2025.1 before 7.2026.6; from 7.0.0 before 7.1.0; from 6.0.0 before 6.39.0; from 5.20.0 before 5.88.0; from 4.1.144 before 4.1.2.191.56; from 5.181 through 5.201.2 — fixed in 4.1.2.191.56, 5.88.0, 6.39.0, 7.1.0, 7.2026.6
How to fix
Upgrade to a fixed version: Payara Server 4.1.2.191.56, 5.88.0, 6.39.0, 7.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12986 or the next vulnerability affects your stack