What’s Vulnerable › Vulnerabilities
CVE-2026-12988: WP 2FA < 3.1.1.2 - Account Takeover via 2FA Setup Email Binding
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-07-14
- Weakness: CWE-862
Description
The WP 2FA WordPress plugin before 3.1.1.2 does not verify that the email address supplied during two-factor authentication setup belongs to the user, allowing an attacker who has obtained a user's credentials to redirect the setup verification code to an attacker-controlled email address and take over the account.
Affected products
- WP 2FA: before 3.1.1.2 — fixed in 3.1.1.2
How to fix
Upgrade to a fixed version: WP 2FA 3.1.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-12988 or the next vulnerability affects your stack