What’s Vulnerable › Vulnerabilities
CVE-2026-12996
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-08-05
- Weakness: CWE-125
Description
A use-after-free in OpenVPN 2.6.0 through 2.6.20 and 2.7_alpha1 through 2.7.4 allows remote authenticated peers to potentially cause a denial of service or leak memory via crafted packets during TLS session promotion or expiry
Affected products
- Debian Linux: 11.0
- OpenVPN: from 2.6.0 before 2.6.21; from 2.7 before 2.7.5 — fixed in 2.6.21, 2.7.5
How to fix
Upgrade to a fixed version: OpenVPN 2.6.21, 2.7.5. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/ReleaseHistory#openvpn-2621-released-1-july-2026
- https://community.openvpn.net/ReleaseHistory#openvpn-275-released-1-july-2026
- https://community.openvpn.net/Security%20Announcements/CVE-2026-12996
- https://lists.debian.org/debian-lts-announce/2026/07/msg00013.html
Get alerted when CVE-2026-12996 or the next vulnerability affects your stack