What’s Vulnerable › Vulnerabilities
CVE-2026-13055: Server crash via aggregation pipeline expression with compound wildcard index specification
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-24
- Weakness: CWE-617
Description
The `$_internalIndexKey` aggregation expression can be used by any authenticated user to crash a MongoDB server (mongod). The expression fails to handle compound wildcard index specifications, triggering an internal consistency check that aborts the server process. The user must be able to run an aggregation pipeline.
Affected products
- MongoDB: from 7.0.0 before 7.0.39; from 8.0.0 before 8.0.28; from 8.2.0 before 8.2.12; from 8.3.0 before 8.3.7 — fixed in 7.0.39, 8.0.28, 8.2.12, 8.3.7
How to fix
Upgrade to a fixed version: MongoDB 7.0.39, 8.0.28, 8.2.12, 8.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13055 or the next vulnerability affects your stack