What’s Vulnerable › Vulnerabilities
CVE-2026-13058: Transaction Command Insufficient Input Validation Leading to Process Termination
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-24
- Weakness: CWE-617
Description
An authenticated user with basic write privileges can cause the mongod process to terminate abnormally by sending a crafted transaction command with an incomplete set of required fields. The issue stems from inconsistent validation across related transaction command parameters, resulting in a fatal internal invariant failure and denial of service.
Affected products
- MongoDB: from 8.0.0 before 8.0.28; from 8.2.0 before 8.2.12; from 8.3.0 before 8.3.7 — fixed in 8.0.28, 8.2.12, 8.3.7
How to fix
Upgrade to a fixed version: MongoDB 8.0.28, 8.2.12, 8.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13058 or the next vulnerability affects your stack