What’s Vulnerable › Vulnerabilities
CVE-2026-13059: Improper Validation of Client-Supplied Command Parameters Allowing Role-Based Access Control Bypass
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-24
- Weakness: CWE-807
Description
An authenticated user with low privileges may be able to perform unauthorized reads and writes on data protected by role-based query-level access controls, due to insufficient validation of certain client-supplied command parameters. The issue affects find, update, delete, and aggregate commands in non-apiStrict configurations.
Affected products
- MongoDB: from 7.0.0 before 7.0.39; from 8.0.0 before 8.0.28; from 8.2.0 before 8.2.12; from 8.3.0 before 8.3.7 — fixed in 7.0.39, 8.0.28, 8.2.12, 8.3.7
How to fix
Upgrade to a fixed version: MongoDB 7.0.39, 8.0.28, 8.2.12, 8.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13059 or the next vulnerability affects your stack