What’s Vulnerable › Vulnerabilities
CVE-2026-13062: MongoDB mongos Improper Validation of Internal Flags in Queryable Encryption Write Commands on Sharded Clusters
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-24
- Weakness: CWE-441
Description
An authenticated user with write privileges on a Queryable Encryption-enabled collection may be able to modify internal encryption metadata fields that are intended to be server-controlled, by sending crafted write commands through the mongos router on a sharded cluster. This can result in corruption of encrypted query correctness.
Affected products
- MongoDB: from 7.0.0 before 7.0.39; from 8.0.0 before 8.0.28; from 8.2.0 before 8.2.12; from 8.3.0 before 8.3.7 — fixed in 7.0.39, 8.0.28, 8.2.12, 8.3.7
How to fix
Upgrade to a fixed version: MongoDB 7.0.39, 8.0.28, 8.2.12, 8.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13062 or the next vulnerability affects your stack