What’s Vulnerable › Vulnerabilities
CVE-2026-13063: libmongocrypt Improper Input Validation Leading to Process Termination
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-24
- Weakness: CWE-190
Description
An authenticated user with standard read/write privileges can cause the mongod process to terminate due to an out-of-memory condition by sending a crafted aggregation command. MongoDB's libmongocrypt library insufficiently validates payload-supplied values, which can result in an excessively large memory allocation.
Affected products
- MongoDB: from 8.2.0 before 8.2.12; from 8.3.0 before 8.3.7 — fixed in 8.2.12, 8.3.7
How to fix
Upgrade to a fixed version: MongoDB 8.2.12, 8.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13063 or the next vulnerability affects your stack