What’s Vulnerable › Vulnerabilities
CVE-2026-13067: tlsCATrusts Role Restriction Not Enforced via PROXY Protocol v2 on Unix Domain Socket
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-24
- Weakness: CWE-863
Description
When PROXY protocol v2 is used on the Unix domain socket path, roles derived from X.509 client certificates may not be validated against the configured tlsCATrusts allow-list. This can result in unintended role assignments following MONGODB-X509 authentication. Affected scenarios require local access to the proxy Unix domain socket and a valid X.509 certificate issued by a trusted certificate authority.
Affected products
- MongoDB: from 8.0.0 before 8.0.28; from 8.3.0 before 8.3.7 — fixed in 8.0.28, 8.3.7
How to fix
Upgrade to a fixed version: MongoDB 8.0.28, 8.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13067 or the next vulnerability affects your stack