What’s Vulnerable › Vulnerabilities
CVE-2026-13068: MongoDB mongos Improper Authorization Check in Cursor Termination Allowing Cross-Database Privilege Misuse
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-22 · updated 2026-10-24
- Weakness: CWE-863
Description
An authenticated user holding cursor termination privileges on one database may incorrectly be permitted to terminate active cursors on a separate database, disrupting ongoing query operations for other users. The behavior stems from an authorization check that does not correctly scope privileges to the appropriate namespace.
Affected products
- MongoDB: from 7.0.0 before 7.0.39; from 8.0.0 before 8.0.28; from 8.2.0 before 8.2.12; from 8.3.0 before 8.3.7 — fixed in 7.0.39, 8.0.28, 8.2.12, 8.3.7
How to fix
Upgrade to a fixed version: MongoDB 7.0.39, 8.0.28, 8.2.12, 8.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13068 or the next vulnerability affects your stack