What’s Vulnerable › Vulnerabilities

CVE-2026-13117

Description

An incomplete guard in OpenVPN 2.6.0 through 2.6.20 and 2.7_alpha1 through 2.7.4 allows remote authenticated peers to trigger a use-after-free during TLS session promotion, potentially leading to a denial of service or memory leakage

Affected products

How to fix

Upgrade to a fixed version: OpenVPN 2.6.21, 2.7.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-13117 or the next vulnerability affects your stack