What’s Vulnerable › Vulnerabilities

CVE-2026-13149: brace-expansion: DoS via exponential-time expansion of consecutive non-expanding {} groups

Description

brace-expansion through 5.0.6 is vulnerable to denial of service. The expand() function exhibits exponential-time complexity in the number of consecutive non-expanding '{}' brace groups. An attacker who passes a crafted string to expand(), directly or transitively, can cause significant CPU consumption and event-loop blocking. The max option does not mitigate this, as it bounds the output size rather than the recursion work.

Affected products

How to fix

Upgrade to a fixed version: Npm Brace-Expansion 5.0.7, 1.1.16, 2.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-13149 or the next vulnerability affects your stack