What’s Vulnerable › Vulnerabilities
CVE-2026-13210: Incorrect Authorization in GitLab
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-28
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.7 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that under certain conditions could have allowed an authenticated user to access CI/CD variables outside their intended environment scope due to improper input validation in the environment scope pattern matcher.
Affected products
- GitLab: from 15.7.0 before 19.1.8; from 19.2.0 before 19.2.6; from 19.3.0 before 19.3.2 — fixed in 19.1.8, 19.2.6, 19.3.2
How to fix
Upgrade to a fixed version: GitLab 19.1.8, 19.2.6, 19.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13210 or the next vulnerability affects your stack