What’s Vulnerable › Vulnerabilities
CVE-2026-1322: Business Logic Errors in GitLab
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-06-17
- Weakness: CWE-840
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.0 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an authenticated user with a read_api scoped OAuth application to create issues and add comments to issues in private projects due to improper authorization.
Affected products
- GitLab: from 16.0.0 before 18.9.7; from 18.10.0 before 18.10.6; from 18.11.0 before 18.11.3 — fixed in 18.10.6, 18.11.3, 18.9.7
How to fix
Upgrade to a fixed version: GitLab 18.10.6, 18.11.3, 18.9.7. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/05/13/patch-release-gitlab-18-11-3-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/587270
- https://hackerone.com/reports/3508895
Get alerted when CVE-2026-1322 or the next vulnerability affects your stack