What’s Vulnerable › Vulnerabilities

CVE-2026-13320: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.7 before 18.11.7, 19.0 before 19.0.4, and 19.1 before 19.1.2 that under certain conditions could have allowed an authenticated user to execute arbitrary scripts in another user's browser session due to improper sanitization of user-supplied input.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.11.7, 19.0.4, 19.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-13320 or the next vulnerability affects your stack