What’s Vulnerable › Vulnerabilities
CVE-2026-13341: Prompt Injection and Credential Exposure via Untrusted Analytics Data in Kong Konnect MCP
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-03 · updated 2026-10-25
- Weakness: CWE-20
Description
A vulnerability exists in the Kong Konnect Model Context Protocol (MCP) server prior to version 1.0.0, which could allow a remote attacker to perform an indirect prompt injection attack and execute unintended API requests.
Affected products
- KongHQ mcp-konnect: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: KongHQ mcp-konnect 1.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13341 or the next vulnerability affects your stack