What’s Vulnerable › Vulnerabilities
CVE-2026-13410: Dancer::Plugin::Auth::Google versions before 0.08 for Perl have TLS verification disabled
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-295
Description
Dancer::Plugin::Auth::Google versions before 0.08 for Perl have TLS verification disabled. The default user agent is initialised with SSL_verify_mode explicitly disabled. An attacker with network man-in-the-middle (MITM) capability between the Dancer application and googleapis.com can intercept the OAuth2 token exchange and userinfo fetch, return a forged access_token and user profile, and be logged in to the Dancer application as any Google user.
Affected products
- GARU Dancer::Plugin::Auth::Google: before 0.08 — fixed in 0.08
How to fix
Upgrade to a fixed version: GARU Dancer::Plugin::Auth::Google 0.08. Check the vendor advisory for mitigations.
References
- https://github.com/garu/Dancer-Plugin-Auth-Google/commit/2fdb72527eaa0e11a5c134c597f1e44e37411d95.patch
- https://github.com/garu/Dancer-Plugin-Auth-Google/pull/5
- https://metacpan.org/pod/Furl#HTTPS-requests-claims-warnings!
- https://metacpan.org/release/GARU/Dancer-Plugin-Auth-Google-0.08/changes
- https://security.metacpan.org/patches/D/Dancer-Plugin-Auth-Google/0.07/CVE-2026-13410-r1.patch
- http://www.openwall.com/lists/oss-security/2026/07/17/8
Get alerted when CVE-2026-13410 or the next vulnerability affects your stack