What’s Vulnerable › Vulnerabilities

CVE-2026-13417: Boards plugin denial of service via unvalidated block fields.properties

Description

Mattermost versions 11.9.x <= 11.9.0, 11.8.x <= 11.8.4, 11.7.x <= 11.7.7, 10.11.x <= 10.11.22 fail to validate the type of `fields.properties` on block creation which allows an authenticated user with editor access to a board to crash the Boards plugin worker and trigger a denial of service via a child block whose `fields.properties` is a non-object value. Mattermost Advisory ID: MMSA-2026-00710

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.23, 11.7.8, 11.8.5, 11.9.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-13417 or the next vulnerability affects your stack