What’s Vulnerable › Vulnerabilities
CVE-2026-13426: Client4 fails to validate path parameters
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-22
Description
The Mattermost Go module github.com/mattermost/mattermost/server/public versions < v0.1.22 fail to validate path parameters when constructing API route paths which allows an attacker to redirect API calls to unintended endpoints via crafted IDs containing path traversal components. Mattermost Advisory ID: MMSA-2025-00532
Affected products
- Mattermost github.com/mattermost/mattermost/server/public: from v0.0.0 before v0.1.22 — fixed in v0.1.22
How to fix
Upgrade to a fixed version: Mattermost github.com/mattermost/mattermost/server/public v0.1.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13426 or the next vulnerability affects your stack