What’s Vulnerable › Vulnerabilities
CVE-2026-13442: Langflow is affected by NET Misconfiguration: Use of Impersonation due to multiple unauthenticated and insufficiently authorized API endpoints
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-10-23
- Weakness: CWE-520
Description
IBM Langflow OSS 1.0.0 through 1.10.1 can allow an attacker to reuse another user's FAISS namespace to access owner-only vector content and influence later query results. This causes cross-user information disclosure and limited integrity impact through persistent poisoning of returned results.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.2 — fixed in 1.10.2
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13442 or the next vulnerability affects your stack