What’s Vulnerable › Vulnerabilities
CVE-2026-13444: Langflow is affected by remote code execution, denial of service, path traversal, and exposed credentials due to multiple unauthenticated and insufficiently authorized API endpoints
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-520
Description
IBM Langflow OSS 1.0.0 through 1.10.1 can allow an attacker to access another user's private vector documents by creating their own flow with matching Chroma persist_directory and collection_name values. The attacker receives exact victim content in their workflow output despite having no authorization to read the victim's flow. Additionally, the attacker can pollute the victim's collection by inserting their own documents into the shared namespace.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.2 — fixed in 1.10.2
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13444 or the next vulnerability affects your stack