What’s Vulnerable › Vulnerabilities
CVE-2026-13697: undici vulnerable to cross-user information disclosure and parse-time crash via degenerate private cache directives
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-08-04
- Weakness: CWE-200
Description
undici's cache interceptor mishandles malformed Cache-Control private directives. In undici 7.0.0 up to before 7.29.0 and 8.0.0 up to before 8.9.0, a response carrying a degenerate qualified private directive, such as private set to an empty value, can be stored in the default shared cache and later served to a different caller with the same cache key, disclosing private response bodies and headers including Set-Cookie. Separately, a Cache-Control header that combines an unqualified private directive with a qualified one triggers an uncaught TypeError in the cache-control parser, which rejects the request and, depending on the consumer's error handling, can terminate the process. Both issues affect applications using the cache interceptor in shared mode, including the default configuration. The issues are fixed in undici 7.29.0 and 8.9.0.
Affected products
- undici: from 7.0.0 before 7.29.0; from 8.0.0 before 8.9.0 — fixed in 7.29.0, 8.9.0
How to fix
Upgrade to a fixed version: undici 7.29.0, 8.9.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-4cwx-7wf7-3272
Get alerted when CVE-2026-13697 or the next vulnerability affects your stack