What’s Vulnerable › Vulnerabilities
CVE-2026-13706: UrlShortener extension url validation can be bypassed due to difference between php url parsing and WHATWG
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-10-25
- Weakness: CWE-20
Description
Improper input validation vulnerability in Wikimedia Foundation UrlShortener. This vulnerability is associated with program files includes/UrlShortenerUtils.Php.
Affected products
- Wikimedia Foundation MediaWiki: from 1.43.0 before 1.43.9; from 1.44.0 before 1.44.6; from 1.45.0 before 1.45.4; 1.46.0-rc0 — fixed in 1.43.9, 1.44.6, 1.45.4
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.43.9, 1.44.6, 1.45.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13706 or the next vulnerability affects your stack