What’s Vulnerable › Vulnerabilities
CVE-2026-13726: Multiple Page Generator Plugin – MPG < 4.1.8 - Reflected XSS via mpg_shortcode
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-27 · updated 2026-07-27
- Weakness: CWE-79
Description
The MPG WordPress plugin before 4.1.8 does not sanitise and escape a parameter before reflecting it back in the response, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting against a victim who is induced to send a crafted request.
Affected products
- MPG: before 4.1.8 — fixed in 4.1.8
How to fix
Upgrade to a fixed version: MPG 4.1.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-13726 or the next vulnerability affects your stack