What’s Vulnerable › Vulnerabilities

CVE-2026-1387: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 15.6 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that could have allowed an authenticated user to cause Denial of Service by uploading a malicious file and repeatedly querying it through GraphQl.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.6.6, 18.7.4, 18.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-1387 or the next vulnerability affects your stack