What’s Vulnerable › Vulnerabilities

CVE-2026-1388: Inefficient Regular Expression Complexity in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 9.2 before 18.7.5, 18.8 before 18.8.5, and 18.9 before 18.9.1 that could have allowed an unauthenticated user to cause regular expression denial of service by sending specially crafted input to a merge request endpoint under certain conditions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.7.5, 18.8.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-1388 or the next vulnerability affects your stack