What’s Vulnerable › Vulnerabilities

CVE-2026-14181: @fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths

Description

@fastify/middie versions 9.1.0 through 9.3.2 fail to guard the URL normalization step used by the standalone engine when incoming request paths contain malformed percent-encoded sequences. Inputs such as an incomplete percent escape or a truncated multibyte sequence cause the underlying decoder to throw synchronously, and the exception escapes the middie normalize step and terminates the Node.js process. The bypass affects applications that call middie.run directly on the standalone engine API, causing an immediate denial of service for all connected clients until restart. Applications using the Fastify plugin path are not affected because Fastifys error handler catches the exception. Patches: upgrade to @fastify/middie 9.3.3. Workarounds: migrate from the standalone engine API to the Fastify plugin path, where the framework error handler catches the exception.

Affected products

How to fix

Upgrade to a fixed version: fastify middie 9.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-14181 or the next vulnerability affects your stack