What’s Vulnerable › Vulnerabilities
CVE-2026-14182: Customer Email Verification for WooCommerce < 3.2.6 - Unauthenticated Account Takeover via Type-Juggling Authentication Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-08-26
- Weakness: CWE-287
Description
The Customer Email Verification for WooCommerce WordPress plugin before 3.2.6 does not correctly validate the email-verification activation code, relying on a loose comparison that an attacker can satisfy with a crafted value type, allowing unauthenticated users to verify and take over the account of any registered user who has not yet confirmed their email address.
Affected products
- Customer Email Verification for WooCommerce: from 2.4.0 before 3.2.6 — fixed in 3.2.6
How to fix
Upgrade to a fixed version: Customer Email Verification for WooCommerce 3.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14182 or the next vulnerability affects your stack