What’s Vulnerable › Vulnerabilities
CVE-2026-14188: Easy Appointments < 3.12.28 - Contributor+ Customer Data Disclosure
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-08-10
- Weakness: CWE-200
Description
The Easy Appointments WordPress plugin before 3.12.28 does not perform a per-request capability or nonce check on one of its customer-listing handlers, allowing authenticated users with contributor-level access to read every stored customer's personal information.
Affected products
- Easy Appointments: before 3.12.28 — fixed in 3.12.28
How to fix
Upgrade to a fixed version: Easy Appointments 3.12.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14188 or the next vulnerability affects your stack