What’s Vulnerable › Vulnerabilities
CVE-2026-14204: Google Authenticator < 0.56 - 2FA Secret Overwrite via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-08-26
- Weakness: CWE-352
Description
The Google Authenticator WordPress plugin before 0.56 does not verify a CSRF nonce when saving its two-factor setup, allowing attackers to trick a logged-in user into overwriting their own 2FA secret with an attacker-controlled value, which enables two-factor authentication and locks the victim out of their account.
Affected products
- Google Authenticator: before 0.56 — fixed in 0.56
How to fix
Upgrade to a fixed version: Google Authenticator 0.56. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14204 or the next vulnerability affects your stack