What’s Vulnerable › Vulnerabilities
CVE-2026-14223: Easy Appointments < 3.12.28 - Subscriber+ Customer PII Disclosure via IDOR
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-08-10
- Weakness: CWE-639
Description
The Easy Appointments WordPress plugin before 3.12.28 does not verify ownership or capability when returning stored customer details, allowing users with subscriber-level access to read any customer's personal information by iterating an identifier.
Affected products
- Easy Appointments: before 3.12.28 — fixed in 3.12.28
How to fix
Upgrade to a fixed version: Easy Appointments 3.12.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14223 or the next vulnerability affects your stack