What’s Vulnerable › Vulnerabilities
CVE-2026-14224: Easy Appointments < 3.12.28 - Subscriber+ Cross-User Appointment Data Modification via IDOR
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-08-10
- Weakness: CWE-639
Description
The Easy Appointments WordPress plugin before 3.12.28 does not verify that the appointment targeted by its customer-data update action belongs to the current user; the action only checks a shared nonce that any authenticated user can obtain from their own appointment's edit form. A subscriber-level user with an appointment of their own can therefore reuse that nonce to overwrite the customer metadata (email, name, phone, description) of another user's appointment. Because the Easy Appointments WordPress plugin before 3.12.28 then treats that metadata as the appointment's contact data, a subsequent administrator status change with customer notifications enabled delivers the victim's appointment notification to the attacker-controlled email address.
Affected products
- Easy Appointments: before 3.12.28 — fixed in 3.12.28
How to fix
Upgrade to a fixed version: Easy Appointments 3.12.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-14224 or the next vulnerability affects your stack